Global AQ forecast products experiencing degrade quality

Incident Report for Tomorrow.io

Resolved

Data has backfilled and global AQ forecast products are returning to normal.
Posted Jun 12, 2025 - 00:26 UTC

Monitoring

Global AQ forecast products are currently experiencing degraded quality in the short-term, but quality is expected to return to normal as this issue is resolved within the next few hours.
Posted Jun 12, 2025 - 00:01 UTC