Stale Satellite Cloud Layer

Incident Report for Tomorrow.io

Resolved

The satellite cloud layer was missing from approximately 3:53-4:22pm EDT, but the previous data issue has been resolved, and the satellite cloud layer is once again functioning as expected.
Posted Mar 10, 2025 - 20:40 UTC

Investigating

The satellite cloud layer on the Tomorrow.io platform is currently stale due to an upstream data issue. No estimated return to normal functionality is available at this time.
Posted Mar 10, 2025 - 20:00 UTC
This incident affected: Web Application.