Lightning and weather alerts relayed via SMS may be delayed for some EU Customers

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 14:20 UTC

Identified

Lightning and weather alerts received via SMS delivery in the EU may be delayed for some users.
Posted Dec 17, 2025 - 23:11 UTC
This incident affected: Web Application and API (Alerts API, Notifications API).