NextGen Customers: Lightning Probability Layer Not Updating Due to Upstream Data Outage

Incident Report for Tomorrow.io

Resolved

The disruption affecting the Lightning Nowcast layer has been resolved - the layer is now functioning normally.

Thank you for your patience!
Posted Jun 09, 2025 - 15:22 UTC

Identified

We are currently experiencing a disruption in our Lightning Nowcast layer, which has not received new data since 2025-06-07 08:01 UTC. This resulted in stale tiles being displayed across affected areas, impacting the expected real-time behavior of lightning probability visuals.

The root cause has been identified as a data issue with the upstream source - we’ve implemented a platform-side fix to remove the outdated data.

We are continuing to monitor the situation and will provide further updates as necessary.

Thank you for your patience,
The Tomorrow.io Team
Posted Jun 09, 2025 - 09:03 UTC
This incident affected: Web Application.