Data Issue in Free Weather Forecasting App
Incident Report for Tomorrow.io
Resolved
This incident has been resolved.
Posted Nov 10, 2024 - 17:29 UTC
Investigating
We’re currently experiencing issues with data not populating in our free Weather App. Our team is actively investigating the cause and working to resolve it as quickly as possible. Thank you for your patience.
Posted Nov 10, 2024 - 15:39 UTC