Degraded real-time/nowcast precipitation data for portions of the Americas - excluding areas in the United States and Canada with weather radar coverage.

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 21:59 UTC

Monitoring

There was an issue with upstream data quality that impacted Tomorrow.io weather data. Upstream data has improved and we are continuing to monitor the impacted weather data.
Posted Mar 03, 2025 - 20:47 UTC

Identified

We are investigating an issue that is degrading real-time/nowcast precipitation data across the Americas. However, areas that are covered by weather radar across the United States and Canada are not impacted. We will update this page as more information is available or once this incident has been resolved.
Posted Mar 03, 2025 - 19:30 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.