Latency in UP products in certain areas

Incident Report for Tomorrow.io

Resolved

The upstream data flow issue has been resolved, and UP Nowcast products for the affected areas are returning to normal.
Posted May 31, 2025 - 01:02 UTC

Identified

An issue causing latency in data for the UP-Australia, UP-Central America, and UP-Global (Classic) products has been identified. Data flow has resumed and products are expected to catch up shortly.
Posted May 31, 2025 - 00:57 UTC
This incident affected: Web Application.