Stale North Atlantic Flight Tracks

Incident Report for Tomorrow.io

Resolved

The North Atlantic Tracks are now updating as expected.
Posted Jul 27, 2025 - 13:20 UTC

Identified

An upstream data issue is causing a delay in update to the North Atlantic Flight Tracks. The newest data will be published as soon as it is available.
Posted Jul 27, 2025 - 13:09 UTC
This incident affected: Web Application.