Degraded European Precipitation Coverage

Incident Report for Tomorrow.io

Resolved

The upstream data issue has been resolved. Real-time and forecasted precipitation products over the EU are returning to normal.
Posted May 23, 2026 - 01:11 UTC

Identified

Radar precipitation data is experiencing issues affecting hour 12Z; resulting in degraded real-time and forecasted precipitation coverage across the EU. We are currently monitoring the issue and working toward resolution.

Thank you for your patience!
Posted May 22, 2026 - 11:46 UTC
This incident affected: API (Timeline API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).