Upstream Outage - degraded or missing precipitation data for portions of eastern Europe, western/central Asia (including India), and eastern Africa

Incident Report for Tomorrow.io

Identified

An upstream data outage is again resulting in degraded real-time and forecasted precipitation data for portions of eastern Europe, western/central Asia (including India), and eastern Africa where there is no supplemental radar data.
Posted Mar 18, 2026 - 23:11 UTC

Monitoring

All components are operational, but the upstream vendor is continuing work on the issue. We are monitoring system stability on our end.
Posted Mar 17, 2026 - 19:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 16, 2026 - 17:55 UTC

Investigating

We are currently investigating this issue.
Posted Mar 16, 2026 - 16:00 UTC
This incident affects: API (Timeline API, Map API) and Web Application - Platform (Web Application, Tiles).