Degraded Quality and Lower Resolution Precipitation Data for Many Locations Globally

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Quality and resolution of precipitation data has returned to normal.
Posted Mar 05, 2025 - 18:10 UTC

Investigating

We are currently investigating an issue that is resulting in degraded quality and lower resolution precipitation data. The issue is most notable across the Continental United States and Europe. Additional updates will be provided as they become available.
Posted Mar 05, 2025 - 17:23 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.