Missing/Degraded precipitation data over Central American region and Atlantic Ocean

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Classic and NextGen are performing as expected across Central America and the Atlantic Ocean.
Posted Jul 15, 2025 - 01:03 UTC

Update

Update: The upstream issue with satellite (GOES-18) across central America is impacting Classic and NextGen.
Posted Jul 14, 2025 - 21:00 UTC

Identified

We're currently investigating an issue with an upstream satellite causing stale precipitation data to appear over central America and portions of the Atlantic Ocean in Classic, and data to be missing over that region in Nextgen.
Posted Jul 14, 2025 - 20:00 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.