Temporary delay in flight information on the insights dashboard

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. The flow of flight data has been restored, and related insights are returning to normal.
Posted Mar 10, 2026 - 23:07 UTC

Identified

An upstream data delay in receiving in flight information will temporarily affect flights displayed on the insights dashboard.
Posted Mar 10, 2026 - 22:18 UTC
This incident affected: Web Application - Platform (Monitors (Insights), Aviation) and API (Insights API).