Delayed or Degraded Nowcast Precipitation Data

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 18:34 UTC

Investigating

We are experiencing delayed or missing precipitation on Classic Nowcast over USA, Europe, India, Japan, Australia, Hawaii, Indonesia, Central America, Caribbean, South America, Asia, Taiwan, Thailand, Vietnam, and most global tiles, as well as missing or delayed NextGen Nowcast over Thailand and Vietnam. We are currently investigating the cause for this issue.
Posted Sep 07, 2026 - 17:41 UTC
This incident affected: API (Timeline API, Map API, Alerts API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).