Upstream Satellite Data missing for Europe, Africa, and Asia

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 02:56 UTC

Monitoring

Upstream satellite data is missing for Europe, Africa, and portions of western and central Asia. We are monitoring for the data to return.
Posted Mar 18, 2025 - 01:45 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.