Stale or Degraded Short-Term Forecast Data for Many Locations Globally
Incident Report for Tomorrow.io
Resolved
After extensive monitoring and review of several subsequent forecast runs we are confident this incident has been resolved as of approximately 00;30 UTC May 23.
Posted May 24, 2024 - 15:32 UTC
Monitoring
A temporary fix has been applied which has improved most of the stale data, but some degraded performance issues may continue. We will update further when the issue has been resolved entirely.
Posted May 23, 2024 - 00:48 UTC
Investigating
We are investigating an issue that is impacting precipitation nowcast across all regions. Precipitation predictions in the 0-3 hour range are degraded on the platform/API. We will update this page once the root cause is identified.
Posted May 22, 2024 - 23:26 UTC
Monitoring
A temporary fix has been applied which has improved most of the stale data, but some degraded performance issues may continue. We will update further when the issue has been resolved entirely.
Posted May 21, 2024 - 06:59 UTC
Investigating
We are currently investigating an issue that is resulting in short-term forecast data to become stale or degraded. These impacts are primarily focused across the United States, Europe, Japan, Australia, and Brazil, and are most apparent within the first 6 hours of the forecast.
Posted May 21, 2024 - 06:49 UTC
This incident affected: API (Timeline API, Map API, Insights API, Alerts API, Notifications API) and Web Application.