Degraded Quality of Precipitation Forecasts for Most Locations Globally

Incident Report for Tomorrow.io

Resolved

Quality of precipitation forecasts has returned to normal. This incident has been resolved.
Posted Oct 21, 2025 - 02:45 UTC

Monitoring

Upstream Himawari satellite data has returned over the Eastern Hemisphere. We're continuing to monitor GOES data for a full resolution.
Posted Oct 20, 2025 - 18:57 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 18:16 UTC

Investigating

We are investigating a satellite data issue which is resulting in a degraded quality of precipitation forecasts globally. Minimal impacts to areas such as CONUS, Europe, and Japan where data is sourced from local radar networks. No estimated return to normal functionality is available at this time.
Posted Oct 20, 2025 - 18:09 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API).