Degraded Quality of 0-12 Hour NextGen Forecasts Across the CONUS

Incident Report for Tomorrow.io

Resolved

The issue was fixed earlier this morning and normal operations were restored as of 0900Z.
Posted Jul 04, 2026 - 14:15 UTC

Identified

An internal data issue is resulting in a degraded quality of 0-12 hour NextGen forecasts across the CONUS. No estimated return to normal functionality is available at this time.
Posted Jul 04, 2026 - 01:42 UTC
This incident affected: API (Timeline API, Map API, Insights API, Alerts API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).