Google Cloud outage producing missing data on Platform and API

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 19:56 UTC

Update

Most data is returning and the platform issues have resolved, but we are still seeing a small amount of degraded data working through the system. API performance is also improving.
Posted Jun 12, 2025 - 19:13 UTC

Monitoring

Some services are beginning to recover upstream and data is beginning to repopulate. We're monitoring for stability and a full resolution.
Posted Jun 12, 2025 - 18:55 UTC

Identified

An upstream Google Cloud outage is impacting API and platform customers.
Posted Jun 12, 2025 - 18:00 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.