Weather App (Free Version): Slow Loading Times
Incident Report for Tomorrow.io
Resolved
The issue causing slow loading times in the Weather App (free version) has been resolved. The app is now functioning normally. Thank you for your patience while we worked to address this.
Posted Nov 18, 2024 - 07:21 UTC
Investigating
We are currently investigating an issue causing slow loading times in the Weather App (free version). Our team is actively working to identify the cause and will provide updates as more information becomes available.
Posted Nov 18, 2024 - 05:54 UTC