Delayed CBAM Model Data for Portions of Asia

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 15:21 UTC

Identified

Bespoke CBAM cycles are delayed due to resource constraints. Model runs are finishing but we are monitoring for normal timing to return. Most platform users are unaffected.
Posted Jul 16, 2026 - 01:54 UTC
This incident affected: Web Application - Platform (Web Application, Tiles).