Issues with Radar integration into Unified Precipitation

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 15:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 15:00 UTC

Identified

A processing issue is causing stale radar data to be integrated into realtime unified precipitation. Our engineers are investigating the issue.
Posted Apr 02, 2026 - 14:00 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Tiles, Timeline).