Degraded Nowcast Precipitation Data: Europe, Africa, Middle East

Incident Report for Tomorrow.io

Resolved

The satellite data feed is now restored to full operation and Nowcast Data is updated as expected.
Posted Jun 27, 2026 - 14:49 UTC

Identified

Delayed/missing satellite data from an upstream source is creating degraded Nowcast Precipitation data in non-radar covered areas of Europe, Africa, and the Middle East. We will continue to monitor the data feed.
Posted Jun 27, 2026 - 08:55 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Tiles, Timeline).