Delay in Insights

Incident Report for Tomorrow.io

Resolved

Resolved – Delay in Insights

The issue that began at 08:00 UTC and caused stale insights in the API and on the platform has now been fully resolved.

✅ Monitors continued running without interruption throughout the incident.
📊 All insights are now up to date and functioning as expected.

We appreciate your patience and understanding. If you have any questions or are still experiencing issues, please don’t hesitate to reach out to our support team.
Posted Jun 23, 2025 - 09:32 UTC

Monitoring

We’re currently experiencing a delay in calculating insights that began at 08:00 UTC. This issue was caused by a problem during routine system maintenance.

What you need to know:
Your monitors are still running as expected and are not affected. However, the insights shown in the platform may appear outdated (stale).

Our team is actively working to resolve this, and we’ll keep you updated as we make progress.

Thanks for your understanding and patience.
Posted Jun 23, 2025 - 09:16 UTC
This incident affected: Web Application and API (Insights API).