Weather data updates have been restored, and affected services are receiving current data again.
The issue, which began at 08:45 UTC, resulted in stale weather data across the platform for approximately one hour. Our team identified the cause and restored normal data ingestion.
We will continue to monitor the system to ensure ongoing stability.
Posted Jun 03, 2026 - 09:54 UTC
Investigating
Start Time: 08:45 UTC
We are investigating an issue affecting weather data updates. As a result, weather data across the platform may be stale, with no new data updates received for approximately the last hour.
Our team is actively working to restore normal data refreshes and will provide additional updates as they become available.
Posted Jun 03, 2026 - 09:12 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline, Aviation, Lightning, Weather Reports, AI Studio Blocks).