Partial Degraded or Missing Precipitation Data

Incident Report for Tomorrow.io

Resolved

Data has been restored.
Posted Mar 16, 2026 - 13:40 UTC

Identified

An upstream data issue has caused missing or degraded precipitation data over eastern Europe, western/central Asia (including India), and Africa where there is no supplemental radar data.
Posted Mar 16, 2026 - 11:06 UTC
This incident affected: API (Timeline API) and Web Application - Platform (Tiles, Timeline).