Degraded Quality of Classic and NextGen Precipitation Products (Real-Time and Forecast) for Many Locations Globally

Incident Report for Tomorrow.io

Resolved

The upstream satellite data issue has been resolved as of 09:00 UTC. Classic and NextGen precipitation products (Real-Time and Forecast) have returned to normal functionality across all affected regions.
Posted Sep 23, 2026 - 09:00 UTC

Identified

An upstream satellite data issue is resulting in a degraded quality of Classic and NextGen precipitation products (Real-Time and Forecast) since approximately 21:15 UTC across Europe, Africa, Western/Central Asia, along with other locations covered by Meteosat without radar coverage. No estimated return to normal functionality is available at this time.
Posted Sep 22, 2026 - 23:27 UTC
This incident affected: API (Timeline API, Map API, Alerts API) and Web Application - Platform (Web Application, Monitors (Insights), Alerts, Tiles, Timeline).