Stale Data for Severe Weather Events and Additional Tiles

Incident Report for Tomorrow.io

Resolved

Incident Time:
-Started: 08:20 UTC
-Resolved: 09:00 UTC

We experienced a delay in the generation of Severe Weather Events tiles, along with additional tile layers including Overlays and NATs, beginning at 08:20 UTC. The issue was identified as elevated errors from a background worker process.

The issue was resolved as of 09:00 UTC. All tile generation has returned to normal operation.

We apologize for the inconvenience and appreciate your patience.
Posted Dec 08, 2025 - 08:00 UTC