Increased geostationary satellite latency affecting precipitation layer

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 14:28 UTC

Investigating

Increased latency from GOES-18, GOES-19, and Himawari-9 are affecting satellite-derived precipitation products (realtime and 0-3 hours) in both Classic and Nextgen. Data will be slow or stale on the timeline.

Affected areas include:
Portions of Japan (areas without radar inputs)
Pacific Ocean
Portions of Hawaii (areas without radar inputs)
Portions of Alaska (areas without radar inputs)
Central America
South America
Portions of Caribbean (areas without radar inputs)
Portions of CONUS (areas without radar inputs)
Posted Sep 23, 2025 - 13:30 UTC
This incident affected: API (Timeline API).