Degraded Global Nowcast

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 14:25 UTC

Identified

An upstream data outage is causing degraded nowcast across the globe. We are working to restore this data and will update this page once the once nowcast products are functioning as expected.
Posted Mar 20, 2025 - 04:26 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.