Degraded Unified Precipitation Data across Europe, Africa, and the Middle East.

Incident Report for Tomorrow.io

Resolved

Issue resolved, data is now operational.
Posted Jul 07, 2026 - 11:54 UTC

Investigating

Real-time and nowcast precipitation products may be degraded in some regions across Europe, Africa, and the Middle East.

We are actively investigating the issue and will provide updates as more information becomes available.
Posted Jul 07, 2026 - 07:00 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application).