Weather Reports Users: Display Issues with Tropical Cyclones Layer Across Widgets and HyperCast

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Tropical cyclones are now displaying as expected.
Posted Jul 31, 2025 - 13:37 UTC

Identified

We're currently experiencing display issues with the Tropical Cyclones layer displaying on Weather Reports:

Tropical Cyclones may not be visible in some areas of HyperCast, the Snapshot widget, and the Outlook widget.

This also affects some Weather Report Snapshot widgets when the Tropical Cyclones layer is enabled.

Our team is actively working to resolve the issue and will provide an update as soon as it's fixed.
If you have any questions or need additional support, please don’t hesitate to reach out to us at support@tomorrow.io.

Thank you for your patience!
Posted Jul 31, 2025 - 12:59 UTC
This incident affected: Web Application.