Current Weather Data is Stale or Missing for the Continental United States

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Current weather data is now up-to-date and functioning as expected across the Continental United States.
Posted Mar 05, 2025 - 17:56 UTC

Investigating

We are currently investigating an issue that is resulting in stale or missing current weather data for the Continental United States.
Posted Mar 05, 2025 - 17:52 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.