Stale Precipitation Data Over Portions of Europe

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 22:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 05, 2025 - 12:08 UTC

Identified

We have investigated and identified an issue with an upstream source, resulting in stale (approximately one hour) precipitation data over portions of Europe. As a result of this stale data, precipitation forecasts are degraded for the affected regions. Alternative solutions will be sought to improve the timeliness of precipitation data.
Posted Nov 05, 2025 - 12:07 UTC
This incident affected: API (Timeline API, Map API, Alerts API, Notifications API) and Web Application.