Incident Update – Monitoring System Disruption

Incident Report for Tomorrow.io

Resolved

Our engineering team deployed a fix and has confirmed that the system is operating normally. We will continue to monitor performance to ensure continued stability.

Thank you for your patience, and we apologize for the inconvenience this may have caused.
Posted Jul 15, 2025 - 15:16 UTC

Identified

We’re currently experiencing a disruption in our monitoring system that began at 09:30 UTC. At the moment, insight-based monitors are displaying outdated data, and alerts are not being sent as expected.

Our engineering team has identified the issue and is deploying a fix. We’ll share another update once the resolution is confirmed.

We apologize for the inconvenience and appreciate your patience.
Posted Jul 15, 2025 - 14:30 UTC
This incident affected: Web Application and API (Events API, Insights API, Alerts API).