Degraded Nextgen precipitation tile forecasts

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 21:53 UTC

Identified

The issue has been confined to precipitation accumulation data for Europe only as we work on a resolution.
Posted Aug 21, 2026 - 15:28 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 11:53 UTC

Investigating

Stale precipitation forecasts are presently being served in tile forecasts for hours 6-42 in Brazil and Europe. We're investigating the issue.
Posted Aug 21, 2026 - 06:00 UTC
This incident affected: API (Map API) and Web Application - Platform (Tiles).