Global Precipitation data issues

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 20:36 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 04, 2025 - 19:30 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 04, 2025 - 19:29 UTC

Identified

Our engineers are working through a transition of upstream satellite data providers that could produce intermittencies in the global precipitation layer. This incident will be resolved when the transition is complete and the products are stable.
Posted Apr 04, 2025 - 19:20 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.