CBAM Israel Super Region Delayed

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 19, 2026 - 13:51 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 19, 2026 - 13:50 UTC

Identified

A data issue is resulting in a delay for the CBAM Israel super region.
Posted Jul 18, 2026 - 18:07 UTC
This incident affected: Web Application - Platform (Web Application, Tiles).