Europe/Africa Degraded Nowcast Precipitation Data

Incident Report for Tomorrow.io

Resolved

The upstream Meteosat-10 satellite data issue has been resolved. The outage impacted data availability from **2025-06-17 11:00 UTC** until **2025-06-19 09:00 UTC**, resulting in degraded nowcast precipitation data over non-radar regions of Europe and Africa.

Data ingestion has resumed and all affected services have returned to normal operation.
Posted Jun 18, 2026 - 11:54 UTC

Monitoring

An upstream satellite data issue is causing degraded nowcast precipitation data over non-radar regions of Europe and Africa. We are monitoring the feed.
Posted Jun 17, 2026 - 11:14 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Tiles, Timeline).