Increased realtime and nowcast Unified Precipitation latency

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 20:15 UTC

Identified

We're performing background task maintenance that is causing a spike in latency in our Unified Precipitation nowcast and realtime products. 0-3h precipitation on the platform are about 30 minutes stale.

We're working to complete this maintenance as quickly as possible.
Posted Jun 04, 2026 - 19:30 UTC
This incident affected: API (Timeline API, Map API) and Web Application - Platform (Web Application).