Widespread realtime and forecast data outage

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 15:06 UTC

Update

Data is improving as the fix trickles through the system. We're continuing to monitor for missing or degraded data but systems are again operational.
Posted Sep 14, 2025 - 13:27 UTC

Monitoring

We've implemented a fix and are currently monitoring realtime and forecast data. Stale and degraded data is being flushed from the system.
Posted Sep 14, 2025 - 12:58 UTC

Update

Nowcast and realtime precipitation impacts are spreading globally as we work to resolve the root cause.
Posted Sep 14, 2025 - 12:07 UTC

Identified

We've identified the root cause of the issue, but it's also affecting many other weather products including global realtime weather data and forecast model feeds.
Posted Sep 14, 2025 - 11:35 UTC

Investigating

Nowcast and realtime precipitation data are missing for portions of the globe, including CONUS, Canada, and Mexico. Other areas are less affected but some fragmented/incomplete precipitation products are being produced. We're investigating the source of the issue.
Posted Sep 14, 2025 - 10:30 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.