Degraded Precipitation Data - US Area

Incident Report for Tomorrow.io

Resolved

The issue affecting precipitation data quality and resolution for products in the U.S. has been resolved. All systems are now functioning as expected.

Thank you for your patience!
Posted Mar 06, 2025 - 08:23 UTC

Identified

We are experiencing degraded precipitation data quality and resolution for products in the U.S. This issue will persist until further notice as we work on a resolution.

We will provide updates as soon as more information is available, thank you for your patience.
Posted Mar 06, 2025 - 07:22 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.