Degraded Precipitation Data in Europe

Incident Report for Tomorrow.io

Resolved

The data feed has returned to normal and precipitation data in Europe is now performing as expected.
Posted Jul 20, 2026 - 11:15 UTC

Identified

An upstream data issue is causing degraded precipitation data over Europe. We will continue to monitor the feed and will update when it returns to normal.
Posted Jul 20, 2026 - 10:54 UTC
This incident affected: Web Application - Platform (Tiles, Timeline).