Stale Forecast Data

Incident Report for Tomorrow.io

Resolved

The upstream data issue has been resolved, and forecast data is now current and updating as expected.
Posted Jun 29, 2026 - 01:35 UTC

Update

Some forecast data is beginning to become current again, but a large amount of forecast data remains stale as the upstream data issue persists. We will update further once full resolution occurs.
Posted Jun 28, 2026 - 19:05 UTC

Monitoring

An upstream data issue is causing delayed/stale forecast data. We are monitoring the feed and will update when the information is updating as expected.
Posted Jun 28, 2026 - 14:05 UTC
This incident affected: API (Timeline API, Map API, Insights API) and Web Application - Platform (Web Application, Monitors (Insights), Tiles, Timeline).