CONUS Precipitation data degraded

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 17:56 UTC

Identified

We've implemented a workaround to prevent the bad data from displaying over CONUS. Forecasts remain slightly degraded in the 2-3h timeframe as we implement a fix, but erroneous data is no longer being sent.
Posted Aug 08, 2025 - 19:19 UTC

Monitoring

We've implemented a workaround to prevent the bad data from displaying over CONUS. Forecasts remain slightly degraded in the 2-3h timeframe as we implement a fix, but erroneous data is no longer being sent.
Posted Aug 08, 2025 - 19:15 UTC

Identified

We've identified the root cause of the precipitation data and are investigating potential workarounds while we implement a fix.
Posted Aug 08, 2025 - 18:26 UTC

Investigating

Hour 3 of precipitation forecast data over the continental US is producing erroneous precipitation data over the continental US. We're investigating the root cause of the issue and potential workarounds while we fix the problem.
Posted Aug 08, 2025 - 17:00 UTC
This incident affected: API (Timeline API, Map API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.