Degraded Performance of Calculation of Monitors and Tiles within the Tomorrow.io Platform

Incident Report for Tomorrow.io

Resolved

This incident has been resolved. Monitors and tiles within the Tomorrow.io Platform are functioning as expected.
Posted Dec 03, 2025 - 03:58 UTC

Investigating

We are currently investigating an issue which is resulting in degraded performance for the calculation of monitors, as well as tiles within the Tomorrow.io Platform. This issue has been ongoing since approximately 01:10 UTC.
Posted Dec 03, 2025 - 02:39 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application - Platform (Web Application).