Degraded precipitation products in parts of Africa, Europe, and western/central Asia

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 15:33 UTC

Update

The affected UP products continue to show degraded quality due to an upstream data flow issue with the primary source. Our backup source is running as expected, so the data being displayed remains current.
Posted Feb 15, 2026 - 04:09 UTC

Identified

We are experiencing degraded satellite-based precipitation products in parts of Africa, Europe, India, and Israel. UP products will be most impacted in locations where radar-based measurements are not available.
Posted Feb 15, 2026 - 00:39 UTC
This incident affected: Web Application - Platform (Web Application).