Degraded Realtime and Nowcast Precipitation Data over Italy

Incident Report for Tomorrow.io

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:22 UTC

Identified

There is an upstream data issue that is causing degraded realtime and nowcast precipitation data over Italy. We will continue to monitor the feed until it has returned to normal.
Posted Jul 08, 2026 - 18:26 UTC
This incident affected: Web Application - Platform (Tiles, Timeline).