Stale or Missing Data for Many Products/Layers

Incident Report for Tomorrow.io

Resolved

This issue has been fixed, and data is once again current.
Posted Jul 28, 2025 - 18:09 UTC

Identified

We have an identified an issue that is resulting in stale or missing data for many products/layers since approximately 5:30am ET, including precipitation data (both real-time and forecasted), along with a variety of other weather parameters. A fix has been deployed, and data is expected to be current again in approximately one hour.
Posted Jul 28, 2025 - 16:46 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.