Delayed data for selected weather observations in Israel

Incident Report for Tomorrow.io

Resolved

An upstream data feed has returned observations to normal.
Posted Apr 25, 2025 - 09:10 UTC

Investigating

A delay in receiving ground weather observations may affect displayed data for selected stations in Israel.
Posted Apr 25, 2025 - 03:18 UTC
This incident affected: API (Timeline API, Map API, Historical API, Route API, Locations API, Events API, Insights API, Alerts API, Notifications API) and Web Application.